Intermittent Payment Issues - Degraded Elavon System Status
Incident Report for E-Government Program
Resolved
Elavon has called an all clear on the issue and we have not seen any further issues.
Posted Apr 24, 2024 - 13:45 PDT
Monitoring
We are currently monitoring an issue with the Elavon payment system gateway that is causing intermittent issues with payments. We are following the issue on the Elavon status updates at: https://status.elavon.com/
Posted Apr 24, 2024 - 12:58 PDT
This incident affected: E-Commerce Services.