Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 10, 2026 - 17:00 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 10, 2026 - 13:55 PST
Scheduled
Tuesday February 10th, 5pm - 7pm
1. Employment Relations Board - Additional transaction details added to the Fees Due email notification, in the Case Management System.
2. Department of Environmental Quality - Text language update and new dropdown selections for approved vehicle classifications added in Zero Emissions Rebate application.
Anticipated down time: up to 15 minutes for each application
Systems/Environments affected: Only ERB CMS and DEQ ZEM system listed is expected to be impacted by this maintenance. No additional systems or environments are expected to be impacted.
Posted Feb 09, 2026 - 15:46 PST
This scheduled maintenance affected: Production Custom Applications.